Setting Attitude Setpoints Through RTPS

I’m trying to set attitude setpoint commands using micrortps. I have it all up and running, meaning the client receives the setpoint commands from the agent. I’m using a publisher through the listener. I can even see the attitude setpoints when I run listener vehicle_attitude_setpoint in the pxh console. But the commands aren’t being used by PX4, I can’t get into OFFBOARD mode. The only difference between my attitude setpoint commands through RTPS is that the timestamp is 0. I tried to incorporate the timestamp in my publisher cxx file, but it says it is not a member of the vehicle_attitude_setpoint class. Why wasn’t timestamp included with the vehicle attitude setpoint command? How can I incorporate the timestamp, and how do I get the correct one inside the rtps agent/listener?

Hi I am trying to use micrortps example to perform similar task. The agent app is able to receive some message but after some seconds the communication just stops. I am assuming you were able to establish a reliable communication. It will be helpful if you can share some details like,

  1. what device you used to send and receive uorb messages
  2. What was the baud rate
  3. did you use any sleep between iteration
  4. were the poll and update rate set to defaults.
  5. Did you use Nuttx for client and linux for agent and listener?