RC not working on snapdragon flight

I tried to install my rc receiver but it doesn’t work. I’ve got a taranis plus radio with a delta-8 accst receiver. I connect it on port J15 using the CPPM signal. The receiver is correctly binded and working. PX4 doesn’t see any signal. I tried to change px4.config where there is ‘spektrum_rc start’ but nothing. I see that there is also a ‘snapdragon_rc_pwm’ driver but it tells me command not found. what am I doing wrong?

Snapdragon flight only supports Spektrum serial RC receivers at this point. This is a HW limitation and not software related.

Now I’m using a spektrum spm9645 and a dx6i but it doesn’t work. I succesfully binded, but when I start the px4 and I go on radio tab I see nothing on channel monitor. I’m using the master firmware, and I have the ‘spektrum_rc start’ on px4.config.

edit: Stil trying to resolve this problem. I found that when I open the px4 in serial console I read ‘RC chan 15 not sane, scaling: 0.000000, rev: 0 0260 parameters.cpp’ and ‘WARNING WARNING WARNING RC CALIBRATION NOT SANE! 0272 parameters.cpp’. Could this be my problem? Even if i try to change the default values for channel 15 I received the same error.
I also look into the code of ‘spektrum_rc.cpp’ and I found that the init function works even without the receiver connected, but I always have the var ‘newbytes’ = 0. It looks like a problem with the uart. Any advice?

edit2: I just resolved the problem by myself. I had to remove the blsp.config file on the adsp

I got the same problem, but I do not have a file /usr/share/data/adsp/blsp.config
Where exactly did you remove blsp.config?