Pixhawk 4 mini Spektrum calibration issue


I’m new to Qgroundcontrol and Pixhawk. I need to inform the readers because it might be something small which I may be missing or overlooking.

The issue is that while using Pixhawk 4 mini I can not calibrate my Spektrum controller. It says “Detected 0 radio channels. To operate PX4 you at least need 5 channels.”
I tried the following things:

  • I tried another Pixhawk 4 mini and had the same issue.
  • Made sure that the RC IN connector has the correct wiring.
  • Updated the firmware.

However, when I use the Pixhawk 4 instead of the mini I am able to calibrate the controller with ease.

If anyone can guide and help with the issue I am facing, that would be amazing.

1 Like

I also could not get my X8R working in the DSM/SBUS RC port. http://discuss.px4.io/t/pixhawk-4-mini-and-x8r-not-working/9406 Have you had any luck?

Calibration also worked smoothly with the Pixracer. I could not get it working with the Pixhawk 4 mini for some reason.

1 Like

Hi Junaid, have you managed to get this working with the pixhawk 4 mini?

I am having the exact same issue. I cannot get the DSM reciever to bind to my DX7 spectrum controller and when I try to calibrate I get the same message.

I managed to get it working.

As some users suggested this is a firmware issue with the pixhawk 4 mini. Using master firmware version allowed me to calibrate the spektrum controller. Using the stable firmware version gives error “Detected 0 radio channels. To operate PX4 you at least need 5 channels.”.

I was however still not able to bind my dsmX receiver using master version connected to RC IN. It gave me an error “mag 0 failed: timeout”. To get around this I first binded my receiver with my controller using a different pixhawk (M-robotics X2.1) and then went through the calibration process using master version on the pixhawk 4 mini.

Apologies for the late reply @Reg_Grobler
I have ended up using a Futaba transmitter and receiver with a PixHawk Pro
because Pix hawk mini was hard to work with …