Quadrotor cannot take off

Hello everyone, I am building a new drone with the Holybro S500 V2 kit (https://shop.holybro.com/s500-v2-kitmotor2216-880kv-propeller1045_p1153.html).

However, when I tried to fly it, it couldn’t take off even when I pushed the throttle to about 75%. After several seconds, the motors were very hot (tested with fingertips). I can even smell that something was heated. I feel that the motors are not powerful enough to lift the drone, but there are a lot of videos showing other people were able to fly it. Could you please give some suggestions based on the log file?

Thank you!

Hi @ltr,

Vibrations levels are crazy high, how did you mount the autopilot on the frame? Could you share a picture?

Hi, @bresch. Thanks for your reply. Here are the pictures.

At first, I just used this transparent tape to mount the flight controller.

Later on, I tried a piece of foam under the flight controller.

However, the vibration levels are still crazy high. Here is the new log file: https://logs.px4.io/plot_app?log=96cd1e87-3e45-4dcc-aa13-7bb5afd26a38

Also, the Holybro S500 V2 kit I received doesn’t have anything to reduce the vibrations. Considering the log files posted above, maybe I should buy some vibration absorber and install the flight controller on it?


Please check here if you are on slack.

Hi @mwbb, thanks for your reply. However, I am not in the px4 workspace. How can I join that workspace? Thanks.

I actually solved this issue by flashing ArduPilot firmware and using the default configurations. I guess I will try PX4 later after I finish my current project. Thanks for your help!

I also added a vibration absorbor between the flight controller and the frame. That might solve the issue too.