Quadcopter Fly Away - Inaccurate Altitude Readings

Edit: I can only include 5 images in the post, i will put more in comments

So there are some similar but unresolved posts about this.

Params: https://logs.px4.io/download?log=8203f4d9-8287-40db-b1e4-1ccc40a51e10&type=1

Non-Standard Params: https://logs.px4.io/download?log=8203f4d9-8287-40db-b1e4-1ccc40a51e10&type=3

Flight Log from PREVIOUS Flight: https://logs.px4.io/plot_app?log=9acfbc39-f5ba-4315-9890-65d33ccb0d25


Using: Holybro S500 frame, default pixhawk 4 GPS, pixhawk 4

This configuration flew a previous test flight that was successful with only a low stack error.

In the current test (fly-away) I also mounted a nvidia jetson nano powered by separate 5V BEC which was also powering two cameras. This computer was only powered from the battery and was not connected to the pixhawk as I was just testing idle power draw. The wires from the cameras were a bit long and were bundled up in about 8 rotations each approx 4 cm away from the pixhawk and GPS module.


I cannot include the full log file from the fly-away flight due to the location of the test, however I will do the best to include relevant graphs and describe the situation.

I drove to the test location and powered on the drone. I did NOT perform compass calibration (probably first mistake). I setup a mission that involved taking off and hovering at 5m then flying a four waypoint mission at 15m before landing at takeoff location.
Then I powered up the drone and armed it in “Altitude” mode. I spun up props to 40% and then switched to “Mission”. Quad immediately shot up at probably around 20m/s, hard to tell. Tried to switch to “Land” on transmitter: Quad kept going up. Tried to switch to “Altitude” again: Quad kept going up. At some point during the flight the quad began to start switching off all motors and free falling ~10m before starting up again and continuing to climb aggressively. This happened until it quickly ran out of battery and crash-landed. During this entire process the Quad was unable to hold horizontal position in any mode.


Here are some graphs I assume to be relevant. Of course I can post more if necessary.

And the error messages:

My Notes

The fused altitude was showing negative which may have been why the Quad kept going up: must have been a failsafe. From what I have read before this may be interference on the pixhawk or extreme vibration levels. Aside from this though I cannot tell. Any insight is appreciated