Qgroundcontrol waits for vehicle connection

Dear people,

I do have:

  • pixhawk 4 mini.
  • Jetson TX2
  • Ubuntu 16.04 installed
  • Qground version v3.5.6
  • PX4 firmware 1.9.2 instaalled on QGCS

I have created a hostpot in the drone side according to this link:

On the SDcard side under the /etc/extras.txt
mavlink stop-all
mavlink start -d /devttyS1 -b 921600 -r 20000 -m onboard

The mavors launch looks like this:

<arg name="fcu_url" default="/dev/ttyTHS1:921600"/>
<arg name="host_ip" default="host_IP" />

<include file="$(find mavros)/launch/node.launch">
<arg name="fcu_url" value="$(arg fcu_url)" />
<arg name="gcs_url" default="udp://@$(arg host_ip)" />
<arg name="tgt_system" value="$(arg tgt_system)" />
<arg name="tgt_component" value="$(arg tgt_component)" />

When I run the mavros launch file I get a message in QGCS

"Waiting For Vehicle Connection"

I have also tried the following command:
roslaunch mavros px4.launch fcu_url:="/dev/ttyTHS1:921600" gcs_url:="udp://@IP_host"

And I can see:
Got HEARTBEAT, connected. FCU detected!
[WARN] CMD: Unexpected command 520,result 0
WP: mission received

In the past I could get connected with no problem. Now I can not.

Any ideas or suggestions I would appreciate it :slight_smile:

Thank you all

Hi people,

The problem was solved, it was the firewall :slight_smile: