QGroundControl on Android tablet not recognizing Bluetooth game controller


I’m attempting to follow these steps: https://docs.qgroundcontrol.com/en/SetupView/Joystick.html

I have this GameSir T1 game controller paired over Bluetooth to an Android 4.2.2 tablet that is running QGroundControl v3.3.0.

I set COM_RC_IN_MODE to Joystick/No RC Checks and restarted QGroundControl, but there is no Joystick section under the Gear icon, so I can’t proceed any further. I have Summary, Airframe, Sensors, Radio, Flight Modes, Power, Safety, Tuning, and Parameters, but no Joystick. I tried force stopping the QGroundControl app and rebooting the tablet, but still no luck.

Is there a step missing in the instructions I’m following, or is this an unsupported configuration?


I have it working now. I tried it on a different tablet running Android 7.0. Maybe the Android version was the problem?

I spoke too soon. Now I’m trying to calibrate, but it’s not working. All of the attitude controls say “Not Mapped”, and I’m not finding much information about how to fix them.

I looked under parameters and I see that RC_MAP_ROLL=Channel 1, RC_MAP_PITCH=Channel 2, RC_MAP_YAW=Channel 4, and RC_MAP_THROTTLE=Channel 3. Do I need to change those to something else?


I think it was just that I had started things up in the wrong order. This time I made sure to pair the game controller to the tablet first before starting QGroundControl, and now I’m able to calibrate it.