Yaw control not working, copter spins while in flight

#1

I have a GameSir T1 controller paired with an Android 7.0 tablet running the current version of QGroundControl from the Play Store.

On the Joystick calibration page, the Roll, Pitch, and Throttle controls all work as expected. The roll and pitch are at the center when the right stick is centered, the throttle is at the bottom while the left stick is centered, and these controls all move in sync with the Axis Monitor.

The yaw control is a different story. When the left stick is centered, the yaw is either all the way over to the right (usually) or all the way over to the left (sometimes). It doesn’t respond very well to the left-right motion of the left stick. The Axis Monitor correctly reflects the motion of the stick.

This is in mode 2. In other modes, whichever control is mapped to the left-right motion of the left stick has this behavior.

Here is a video if it’s not clear what I’m trying to say.

Thanks

#2

First thing what version? If you are on a Stable make sure it is the latest stable. If you are on latest stable can you try a daily build? It may have already been fixed.

#3

I’m on the version of QGroundControl from the PlayStore (v3.3.2). I can try checking out the most recent version from GitHub and building the APK.

#4

Daily builds are available from Google Play as well. You don’t need to build yourself.

#5

I also assume this is after you calibrated a couple times to try to get yaw to work correctly.? Looks like some sort of calibration problem .But from the Monitor display it seems like it should calibrate fine since it goes full left/right.

#6

Thank you for responding.

I installed the daily build, but I still have almost the same behavior. The yaw control is still not reacting correctly to the left-right motion of the left stick, while the axis monitor continues to correctly reflect the motion of the stick.

The difference I see between the two versions is that in the stable version I was able to intermittently move the yaw control to the left by fiddling with the left stick, but in the daily build the yaw control stays locked to the right and I can’t finish the calibration procedure.

As a workaround, I tried mapping throttle and yaw to the D-Pad buttons instead of the left stick. I was able to calibrate it that way, but not able to fly it that way. It wouldn’t take off even at full throttle.

Is it possible to map throttle to the up-down movement of the left stick and map yaw to the L2/R2 buttons on the front of the controller?

#7

Discussion moving this GitHub Issue: https://github.com/mavlink/qgroundcontrol/issues/6419

#8

I added screenshots of my summary page to the GitHub issue.