QGC App crashes on Real Device (Android)

I have managed to successfully build the app version “Stable_V4.3” on android. But it crashes with this error in the Application Output:

Another thing is that the exact same build runs successfully on emulator but crashes with the above error on mobile (Arm architectures). (Both Release & Debug)

Help Guyz!

Hi jawad, i am having the exact same problem. Have you found a solution?

Hi @youssef_essam

Yes I was able to solve the problem.

There were some files missing in the ANDROID _SOURCE… directory.

I just tried to build on MacOS, and the directories contents were different. And it worked.

Either they updated the repository, or it was the OS.

I used Stable_V4.3.

Let me know if you need the directory, I’ll attach it.

Can you attach the directory? i have manipulated the androidmanifest.xml file, and moved it with the RES folder to the ANDROID_PACKAGE_SOURCE_DIR directory.
I am also wondering if it’s because my device’s android version is 13 (API level 33).

Just replace this one with your existing directory. You might have to modify API Levels in Android_Manifest.xml file.

Thank you so much Jawad, I will try placing it in my build directory tomorrow and get back to you! Appreciate it alot.

Hi Jawad! I’m struggling to build the android version. Which version of QT are you using? And where i suppose to paste the “ANDROID_PACKAGE_SOURCE_DIR”, inside my local repo of the qgrundcontrol i download from github?



I was using version 5.15.2.

When you execute the build command for Android application the first time, it will fail.

But a directory for that build will be created on the same level as your project.

Paste the Android Source directory in that build folder and run again.

Hopefully it will build and run successfully.

It worked, thanks a lot!