PX4Flow: ground_distance is always zero in ROS

We just started to use the OF camera (https://pixhawk.org/modules/px4flow).

We have successfully installed all the packages needed to run it on ROS (px4flow_node - ROS Wiki). Though the camera works OK, we can see actual video, it seems that the ultrasound sensor does not (“ground_distance: 0.0”). I got this message after displaying the topic: rostopic echo /px4flow/opt_flow. I have tried to figure out a solution, but when we use a second camera, we get the same result. Because of this, the velocity is also zero (“velocity_x” and “velocity_y” messages).

Could you kindly advise us a solution? thank you very much indeed.

Hi all,
we’ve recently acquired a px4flow equipped with the ultrasound sensor.
We connect the px4flow directly to our PC through USB.
When trying to visualize the sensor data using the ROS node, we experience the same problem mentioned above, i.e., ground_distance is 0.
Same issue appears when trying to visualize the data using QGroundControl. Fields ‘ground_distance’, ‘flow_comp_m_x/y’ from OPTICAL_FLOW message, and field ‘distance’ in OPTICAL_FLOW_RAD message are always 0.

Any hint about this problem?