Px4 motors do not spin smoothly

Hi everyone,

For a project I have build a quad using a cube orange fc with 16 inch MN5006 motors. I successfully flown my drone using ardupilot. However for my project I need to use the mavlink trajectory commands. These are sadly not supported in ardupilot.

This is why I want to switch to PX4. However after flashing the firmware and setting up the drone, I have a weird problem with the motors.

When I test the motors using the test interface in qgroundcontrol, the motors spin smooth. However when I arm my drone without changing anything the motors do not spin smooth. They vibrate a lot and make a bad sound.

I already tried changing the esc protocol and default PID values. Still the same issue. (Vibrations however dit become less when going from my PID values to default).

Here is a video showing the problem:

Motors: mn5006 t motor
Esc: f35a t motor
Fc: cube orange
Firmware: latest stable release
Battery: 6s

I don’t see or hear what is wrong from the video I’m afraid. But my guess would be either that it’s “normal” because PX4 is applying controls, so it’s not as smooth as when you just test it, or, that the minimum PWM is too low, and so it’s struggling between off or too slow and rotating properly.

Check the PWM_AUX_MIN or PWM_MAIN_MIN params depending on where the motors are connected to.