I’m trying to install PX4 and launch a simulation with sitl… but I couldn’t finish the installation.
I checked the ROS was successfully installed, but when I checked dependency, I got a error message about sympy version.
It’s saying "Could not find a version that satisfieds the requirement sympy>=1.10.1 … "
I did some googling, but I couldn’t find similar issue.
Hello everyone, I encountered this same problem, and I found a solution that allows my targets of interest to build, one of which is px4_sitl_default, which I am guessing that you may be using. I can run jmavsim, though on some of the machines I have tested this, Gazebo has trouble opening…my new issue may be unrelated to this current one, so I am sharing in hopes something works for you.
I am running Ubuntu 18.04, which uses python 3.6 by default. However, sympy 1.10.1 requires python 3.8 at minimum. I tried upgrading to python 3.8, but had considerable trouble making that work successfully.
A Few Solutions
Staying on Ubuntu 18.04: I moved the sympy requirement to the optional-requirements.txt file similar to what is described in this closed issue on the github repo; the symforce package was causing similar problems, and it turns out that it is not necessary for building.
Migrating to Ubuntu 20.04: Because Ubuntu 20.04 ships with python 3.8, I did not see this error when testing out the toolchain installation and build process on 20.04.