Error in statring jmavsim in sitl

when i write the command :" ```
make px4_sitl jmavsim" this message shows to me “INFO [simulator] Waiting for simulator to accept connection on TCP port 4560” and no simulation starts. so what is the problem ? thanks in advance

@Khaled_Adel Your jmavsim is not starting. Have you followed exactly the PX4 documentation to install all the dependencies?

@Jaeyoung-Lim Yes i followed these instructions : Ubuntu/Debian Linux · PX4 Developer Guide at the first time. And after the problem appeared i followed the following video 💻 Setting up your PX4 development environment on Linux — Getting Started with Drone Development - YouTube which introduce the same previous instructions and the same problem excites.

Are you sure you ran the installation script without the no-sim-tools tag?

@Rohit_Sutradhar, I am facing the same issue. I did follow the same instructions @Khaled_Adel mentioned and ran the script without any tag. I get stuck at the same place.

I even tried changing the connection to UDP at port 14560 (adjusted for instance), following many older suggestions you can find searching for this issue, to no avail.

I just noticed an error message amid the output:

/home/.../PX4-Autopilot/Tools/jmavsim_run.sh: line 62: ant: command not found

Then I found this issue:

So apparently ant is missing. Installed with:

sudo apt install ant

And… now the error message changed, which is Linux lingo for progressing.

Alrighty, the next issue pertains to OpenJDK. I did exactly as described in the following link to disable the problematic feature:

In short:
sudo nano /etc/java-8-openjdk/accessibility.properties

and commented out the line:
#assistive_technologies=org.GNOME.Accessibility.AtkWrapper

Then make px4_sitl jmavsim finally worked!