PX4 Flight Stack Plane Auto Takoff

What is the trick to the madness… Want to execute a plane throw launch. Already setup… Mission with takoff, arm ed, Pixracer, Flight Stack 1.5.3, QCS, Taranis, Dragonlink. I get REJECT AUTO Takoff. Is there any settings like APM? I can’t seem to get it up in the air.


This is a bug that was just fixed.

That’s great dager…

How do I fix this? I’m so new to this. Do I install a fix or other firmware or?


@chief I may have spoken too soon. Can you share the log and any output you saw in QGC?

Please walk us through what you did. Planned a mission with auto takeoff waypoint, synced, etc
Did you press the Takeoff button in QGC or just switch to mission mode?

That would be great if it could be added to the latest stable/beta version. I plan to fly this weekend and could test it out using the Skyhunter. I couldn’t figure out to pull the log file through GCS. I installed the master through GCS but it was 1.5.2 beta. I used both takeoff ways, through the GCS and through my TX.

When you used the transmitter did you switch to takeoff mode or mission mode?
How did you do it through the GCS?

The takeoff mode is completely separate from a mission with a planned takeoff. I’m trying to figure out if that’s part of the problem here. Then we still need to dig into why it was rejected.

I loaded mission with first point to TAKEOFF. I first armed it through my TX, then moved my 6 pos sw to takeoff and nothing. I believe I saw REJECT TAKEOFF message. I also tried to takeoff through GCS by pressing takeoff and sliding the slider and nothing still.

This was with the 1.5.2 beta master FW.

Could it be that the launch or runway takeoff parameters have to do with it?

Ok, then this is different. Please try creating a mission with a TAKEOFF waypoint, then instead of switching to TAKEOFF mode switch to MISSION.

I’ll take a look at making the TAKEOFF mode work for planes.

The mission I had the 1st WP to Takeoff, should of that worked if I also tried it in mission channel through my TX? I think I forgot to mention I tried in Mission channel as well.

It would be nice to try this feature when I go to the ranch. Would I still have any other problems flying, like taking off in stab?

What was the error when you tried switching to mission mode?
Do you have a log file?

Stab will likely be fine, but we should probably find the root cause for the takeoff rejected message.

Wish I knew what steps to take to create logs through GCS, unless they’re in the SD card and can pull through MP.

I can try when I return home and do that test again.

They’re on the SD card and can be pulled with a current version of QGroundControl.

Dumb ?.. but how do you pull them thru the GCS?

Ok… Houston we had a take off. I’m suspecting the Master I loaded was 1.5.2 beta and probably had the changes made.

Loaded the mission, armed it…and moved sw to Takeoff… throttle was slow at first, but when I attempted to throw the plane it revved up… So I know it will work now. I didn’t actually executed the throw because I’m in town.

I have the logs, but I can’t or don’t have the option to upload them here.