PX4 Detected 0 radio channels

i have an RC(SBUS signal) connected to Cube Orange firmware PX4, i have connected Transmitter and Receiver but on QGC “Detected 0 radio channels”. With the same hardware, but with Ardupilot firmware, QGC can detect radio channels. Is the output of CubeOrange firmware PX4 and Ardupilot different??? Or do I need to do something with the parameters on the PX4? Please everyone help me.

I ran into this as well yesterday. It might indeed not work and require fixing.

Can you share some more detail, please?

  • PX4 version?
  • SBUS receiver?
  • How you connected it?

Ok, I just verified this with a Cube Orange on PX4 v1.14 (current release branch) and PX4 v1.13 (current stable), as well as a Cube Orange+ on PX4 v1.14 (current release branch), and it works fine.

My SBUS receiver (FrSky X4R) is connected to RC IN, not SBUSo(ut)! Check that the SBUS/signal pin is correct as well.

Also, check that the param SYS_USE_IO is set to 1, otherwise RC doesn’t work.

Hi, thank you for your support.
It’s just that I’m testing fake RC with STM32, I simulated transmission frame of SBUS to fake RC signal for Cube (PX4). So I tested it on 2 firmwares PX4 and Ardupilot. But on firmware Ardupilot can detect RC signal, from this I make sure I plugged in correct SBUS signal pin for Cube, but it doesn’t work on PX4 firmware.
I checked SYS_USE_IO = 1 but still not working.
I have question why does that work on Ardupilot but with PX4 it doesn’t? Do I need to configure parameters on the PX4?
You can refer to my picture below.
Thank you.

The parsing might be slightly different and it seems to work with the ArduPilot SBUS parser but not the PX4 one. I would try to debug the PX4 one.

I really appreciate you replying to me.
But I still have a question that if I plug my real Rx into PX4 will the PX4 get the same error again?
I have simulated SBUS using STM32, every 100ms will increase the signal of all channels by 100 units and send it by UART(8E2). So I don’t know what the difference is?
Thank you.