PX4 Community Q&A: May 24, 2023

May 24, 2023

Join us


  • Community Announcement
  • Community Q&A
  • General Discussions

:loudspeaker: Community Announcement

A.1 : Release branch for 1.14 has been cut

New things merged to the main branch do not necessarily end up in the release. Additional bug fixes will be ported. Release date is not clear yet. We’re hunting after the last issues.

We’re feeling good about the release. A lot of successful flight tests were conducted. We worked through multiple reported bugs.

One things still hanging at the moment is the PWM calibration: [WIP] PWM calibration problem · Issue #21634 · PX4/PX4-Autopilot · GitHub Feel free to chime in and cooperate on this.

:people_holding_hands: Community Q&A (No deep technical discussions)

:exclamation: Guideline for asking a Question

  1. Specify what you are trying to achieve
  2. Specify what environment / platform you are using
  3. Prepare a Link or Document to help understand if possible
  4. First, ask the question on Discord or create a Github Issue!
  5. If you take over 5 minutes for the question, please continue in Discord or a Github Issue.

Q.1 : Aly/ @princealy ROS2 launch script

From below:

Is it supported to run ROS2, microDDS, and PX4 using one common launch script? Is there an example for that?

Answer: There’s currently no go-to example that works with the latest versions. Once the release is out we want to move back to improving the entire ROS2 workflow. Since Aly is interested to help and contribute we’ll get a forum thread started and already have a draft running.
TheotimeBlg is also interested and wants to cooperate.

Q.2 : @mwbb Apple M based toolchain experience

Does someone else use Apple M-silicon and use the toolchain and has experience with it? Who is the maintainer? @ThomasDebrunner was making it work in the first place.

The Homebrew toolchain setup script works for farhang and jMAVsim works ok after installing both OpenJDKs.

Q.3 : ayham_allarbat No log files available

Making logs by arming, disarming or logger on, logger off there is no log available afterwards. The logger seems to trigger as expected. Board: Holybro pixhawk 6C

The suggested next thing to try is back up the SD card content, format it on e.g. a Windows computer and then try again.

Q.4 : ayham_allarbat MAVLink stream configuration

Using a startup script from 1.11/1.12 releases that adjust the message frequency of a MAVLink telemetry stream for odometry from 30Hz to 100Hz on 1.13 results in a higher message rate seen in MAVLink inspector on the round station but not in mavros.

This could be because the USB MAVLink instance is started in a different way only when something is connected via USB and sends a heartbeat. Depending on the timing when having the stream adjustment command during bootup it could not have an effect. The suggestion is to adjust/add a MAVLink stream mode that has full rate odometry feedback for the use case.

In general, having a companion computer connected over USB is a use case that also @AlexKlimaj is working with. It would be useful to have a configuration option to have a fixed MAVLink instance on the USB port and not have it fail the preflight check when connected (the last part already available in a circuit breaker CBRK_USB_CHK).

Q.5 : SalimTerryLi Apple jMAVsim issue

Some library in jMAVSim/lib at main · PX4/jMAVSim · GitHub doesn’t work properly for him on an ARM-based computer.

@mwbb is trying to reproduce the issue and shares what the necessary additional steps are.

Q.6 : SalimTerryLi Tested his PR for the PWM extender

Now it needs to be reviewed.

and he’s also looking for feedback on

I’m developing my Master’s Thesis, and I’m using the PX4 toolbox in Simulink to design a customized controller for a quadcopter. I want to apply a model design approach, so I want to create the controller in Simulink and then through code generation, I want to perform SITL, PIL and HIL on Gazebo in order to validate my controller and then deploy the generated code on the real drone.
I’m having problems with the simulator I want to use.
Does anyone know how to perform SITL in Gazebo using the PX4 Toolbox in Simulink? I have just two simulators listed on the settings (jMAVsim and Simulink), how can I run my Simulink model on Gazebo?

1 Like

I’m developing my Master’s Thesis, and I’m using the PX4 toolbox in Simulink to design a customized controller for a quadcopter.
I have done a Simulink file where I’m injecting rotor velocities into the quadcopter simulated on jMAVsim, it is like an open loop system. I have to store the system states of the open loop system
because I need them for further calculation (model validation with the mathematical models),but I have a problem.
I need also to read and store the rotor velocities because I have to check if they are the equals to the injected one. How can I read the rotor velocities? I’m using the PX4 read block on Simulink using the esc_report.msg and rpm.msg, but I read 0 as output which is impossible because the drone takes off. How can I fix this problem?

hey @Matteo_Mennea please join us for the call!

Hey everyone!

I am trying to create a launch file that will start PX4, so we can send commands from ROS2 to PX4 using the microDDs bridge.
I have read the following examples:

While these launch ROS2 and connect to PX4 using the bridge, we need a way to first connect the drones to PX4.
The use case is to implement the following using a launch file:

As the multi-vehicle simulation requires gazebo garden, which is not compatible with our environment. How can we get this to work? Are there any examples?

Here are some related threads:
Launch PX4 via ROS2 python launch file - #13 by befaro - uses RTPS not microDDS
ROS2 lidar integration - via python launch file? - unasnwered

Here is my discord question: Discord

Thank you so much!!!

1 Like