Problems with Altitude Hold Mode


I was hoping someone could shed some light on a problem we are having with our quad-rotor.

We are trying to tune our quad-rotor and we have it where is can fly well in stabilized mode. The issue comes when we try to put the quad-rotor into Altitude hold mode. The quad-rotor either just shoots up into the ceiling or it oscillates a lot like comes all the way down to the ground and then back up.

Here is a flight log from one of the flights.

Our setup includes custom quad-rotor, terraranger lidar, px4 flow optical flow and pixracer flight controller.

Also we were wondering if there is a way to completely remove the barometer from the state estimation? We tried using the LPE and unfuse the barometer, however, the quad-rotor would not arm without having the baro in the state estimation.

Any help is appreciated thank you.

I don’t know exact reason, but this may be a clue.

In graphs at about 3:02.5, thrust stick changes a little, Z position control error increases from this point.

Maybe Z position control gains needs calibration.

Thanks for the reply.

We have calibrated the Z position control gains and the drone has more or less the same behavior.

After digging around some older flight logs of the drone when we had position control working we have noticed possibly a clue in the raw acceleration data and the gyroscope data. The current flight logs show a instances where the acceleration and angular speed are much higher than before. This flight log shows data from when position control worked on our drone (couple days before the original post). When compared with the flight log above the IMU data is much different even though the overall flights and environments were very similar.

So we were thinking it could be either bad IMU data or vibrations causing the behavior now. Does this seems reasonable or should we be looking somewhere else as well?