Preflight fail

Hello I am trying to test a prototype quadcopter with a PIXHAWK MINI 3DR. The prototype worked well a couple of times and now is not anymore. It had a little contact on front side of the copter when testing the stabilization(I will try to attach the video)and after that the drone won’t stabilize itself anymore. I get the message “PREFLIGHT FAIL: EKF HIGH IMU ACCEL BIAS” I checked on the commander COM_ARM_EKF_AB to make sure its value was at the default value since that is what I saw online to do (which it is). I kept searching for possible errors and came to find under parameters>system>Sensor Calibration that the default values are way off on what I’m getting after calibration (even when I reset them to default values) I will also try to attach a screenshot of what I am talking about because the values are way off.

I adjusted the GPS unit since it was slightly tilted and made sure the cable connections on the board in hope it would fix the problem but still getting the same preflight fail message.

Any recommendations? I am fairly new to this field

thank you in advance

1 Like

If you calibrated your sensors and the error still occurs then have a look at the COM_ARM… parameters in QGroundControl. You can set the thresholds for the parameters which prevent you.from arming. Of course this is at your own risk of possibly ignoring a problem in the system.

Everything but the flightmode slots (1 and 6) is under the default values.

I keep getting the same message “PREFLIGHT FAIL: EKF HIGH IMU ACCEL BIAS” after setting values to default under sensor calibration and then calibrating the drone. Is there anything else I could check or do to fix this problem?

1 Like

the drone turns on and motors work but it won’t stabilize as it did in the first couple of test :sweat:

This is the last flight log I have, I tested manual and stabilized flight modes.

I’ve have the same issue. Make sure you power on the vehicle while it is sitting flat on the ground, this fixes the issue. I think it has something to do with the estimator getting into a bad state when the vehicle is being carried or moved around while it is in the landed state.

I tried powering vehicle on flat surface and let it be for a minute or two. Then went back to calibrate in QGC see if the preflight fail message disappear but the error persisted. I powered a couple of times and repeated the check but nothing changed. Any other thoughts? :sweat:

Here I attach the last 2 flight logs where the vehicle was powered on a flat surface (table).

It looks like you are trying to arm the quad with the kill switch engaged?

I am turning it on and off as I test it. I have a base where I set the vehicle and vary the angle at which it starts to check the reaction time to stabilize. But whenever I re-calibrate I get the Preflight fail message (always the high IMU accel bias).