Pixracer not powering on when connected to PDB

Hi There,

I am currently using the HolyBro PM06 PDB to power my Pixracer R15 via the power cable that came with the PDB.
I have used this setup previously on another build and it worked fine however i have just finished assembling a Robocat 270 reusing this hardware and when the Pixracer is plugged in via USB both it and the receiver get power.
However when using a Lipo neither the Pixracer nor the receiver get power despite the ESCs initialising.
I have continuity checked all the wires that connect the PDB and flight controller and couldn’t find any breaks and connectors on both ends were intact, so was unsure where to check next.

Any help would be greatly appreciated.
Thanks, Ollie.

Good day, can you attach pls the wiring you have done?

Thank you for your reply, here are some photos.

Good day, looking at the cable miss one Power line…you must have two red cables.
Did you check with a tester?

But it only came with one red wire out of the box?All 6 cables are still connected. Like I said it worked fine on the frame I was using before this and I checked with a multimeter and it seemed like all of the cables were undamaged.

it’s weird… do you have another cable to test?

I don’t have another whole cable, however I have switched around some of the wires and made sure that they are going to the right pins on the connectors but still no luck. I think I will test the ports on both the Pixracer and the PDB and see if either are broken.