Orange Cube Pixhawk is not connecting to any ground stations. and not showing in my device manager

I have an orange cube pixhawk. I am connecting it to my system through the USB and the cube is not showing to my system’s device manager and not even in ground control station software but after connecting to the system via USB the orange and green lights are on mode and after few seconds green light starts blinking. Please resolve the query to how to connect my orange cube to ground control software like mission planner and pixhawk.
Please do the needful.

1 Like

Are you using Mission Planner or QGroundControl?

If Mission Planner you are using ArduPilot and might want to ask over in

In any case, make sure the drivers are installed, and also try a different USB port and cable.

Hello JulianOes,
Thanks for your reply. I am using both QGroundControl and Mission Planner. ArduPilot was uploaded in my orange cube through MissionPlanner, after a couple of days we encountered some issues on cube visibility. The cube is not visible in QGroundControl or MissionPlanner even after connecting USB. It is not visible in device manager as well. Although drivers are updated, and I have also tried connecting by changing the cable and USB port but still cube is not responding. Please let me know if there is any other solution.

Given it worked first, but not anymore, could it be a hardware issue? Also, have you checked that the Cube is properly connected to the base board?