Pixhawk 5x Power Loss

Hello all,

I have an issue with my 5x losing power after plugging in a YRRC FPV Radio Telemetry Air Module into the TELEM1 port.
The issue is after I power on the Pixhawk and plug in the YRRC module while the FC power is on, the air module green connection light starts blinking and after 5 seconds the FC loses power. The same problem occurs if I have the module plugged in before powering on. (Powering the FC, and YRRC module at the same time.) I have checked the pins inside the port, and even tried TELEM2 and 3, the same problem occurs. I have tested 2 of my Wi-Fi modules and the same thing happens, rapid light blinking and power loss.

About 5 minutes before this issue started happening, I swapped the RX & TX cables so it would connect to QGC. After I swapped the cables, it successfully connected to QGC and I powered off. After powering back on, this problem started occurring.
And about a week before this exact setup was making a test flight but lost control and crashed. No visible damage to the battery, FC, or YRRC module.

Full setup:
14.8V battery
F55A Pro II 6S 4 in 1 32 bit ESC
Pixhawk 5x & baseboard
YRRC FPV Radio Telemetry Air Module

Any help would be greatly appreciated,
Thank you!

Did you try to power it from the external power supply? Maybe it just draws too much current.

I have not, I will try that next. I just don’t understand why it would work with this setup one day and not the next, without any changes.


Went back and tried to power on, and it worked.

Disconnected and adjusted my frame. Plugged back in and same issue. But more interesting, I left the YRRC module unplugged and tried to power on and the FC lost power after about 5 seconds. The ESC still has power so I believe it is isolated to the FC. Tried POWER2 and POWER1, both have the same result.