Pixhawk 4 not able to work with PX4 firmware

Hi folks:

I have a strange problem. I am using five Pixhawk 4 controllers, and none of them works with PX4 any more. They run ArduPilot just fine. I can’t figure out what is wrong. These Pixhawk 4’s ran PX4 last year but now they won’t. Very puzzling.

The other strange thing is that the older Pixhawk 1 runs PX4 without a problem.

I’ve tried several versions of PX4, including 1.11.0, 1.11.3, 1.12.2, and 1.12.3. No joy. None of the older versions works either.

Has anyone else seen this problem?


What means “none of them works with PX4 anymore”? Does not flash firmware, or what?
I had similar problem - could not calibrate IMU on new Radiolink Pixhawk. The reason was that I had LPE firmware flashed, but default estimator is EKF2. After I changed estimator type in params ( SYS_MC_EST_GROUP) properly - all worked OK.

To clarify, when I flash PX4 onto a Pixhawk 4, QGC tells me that the firmware has loaded successfully. At that point I hear the tones indicating that it is booting up. Then it freezes up and the parameters never download.

Funny thing is that this does not happen with the Pixhawk 1. So I think something is wrong with the Pixhawk 4.