Pixhawk 4 Mini - No PWM Outputs

#1

I’m trying to configure a standard airplane with a Pixhawk 4 mini flight controller. I think I configured everything correctly and can arm the aircraft, but I’m not getting any PWM signals on the servo / motor outputs. Are there any other steps required to get the PWM outputs working?

#2

Hi supersocks, check the minimum and maximum vales of PWM in the parameter list.

#3

interesting subject. I have pretty much the same problem. My plane is armed and my stick commands have no effect in manual mode.

@supersocks Have you progressed in any way?

#4

Check if you have 5volts on the servo rail

#5

my servo rail has 5 volts on it.

#6

I don’t know what GCS are you using, in general check the radio calibration and if the sliders moves correctly when you move the sticks, arm the pixhawk and it should work fine. I assume you are pressing the prearming switch and then arming the pixhawk with the stick command to enable the PWM outputs.
I use QGroundControl with no major modificatin in the radio parameters, except the ones changed by radio calibration.
If you use Mission Planner may be this video could help you, best success wishes.