Pixhawk 4 mini and the OSD

I just finished setting up a quadcopter with the Pixhawk 4 mini and the Holybro OSD v2 module but can’t seem to get RSSI value to show up on the screen. I’m using a TBS Crossfire Diversity receive,r connected by SBUS, with lots of channel options, one of which is RSSI. How would I incorporate this value in the OSD? It should be automatically included in the SBUS data stream, it just doesn’t show on the OSD.

Rick

If using RSSI on a channel, you have to specify in AgentX on the rx module which channel is used. thsi needs to match what your OSD is set to.

I’m using an SBUS connection and need to include the RSSI info in the data stream. There is no option to set a channel for this in the OSD software.

I am not sure about other firmware, but if you use MWOSD (which supports PX4) you can use RSSI from an RC channel.

I actually have one of the MWOSD boards lying around here somewhere. It’s just kind of big and bulky. I liked the compact size of the Holybro OSD it just doesn’t work right. I’ve tried everything I can to get the Mode display to work, but nothing. It just stays at “STAB”.