Pixhawk 2.4.8 wont connect to inav/beta/or cleanflight

Hi there i have just bought a new pixhawk i am trying to set up have tried inav/beta/cleanflight but non will stay connected i get serial port successfully opened after a few seconds i get serial port successfully closed is this a pixhawk problem do i need to return it or is there a solution i have done several clean installs also should have all the necessary drivers have tried the impulse driver but it does not find controller has any one any solutions
thanks in advance

Hello I too purchased a PixHawk 2.4.8 running px4 1.11 FMU V2 The circuit board has Hex Technologies printed on it. I understand it is likely a clone.

I have no experience yet with inav/beta/cleanflight. I can’t even get my 6 motors to test spin until I find a solution to FrSky SBus and this admittedly legacy PixHawk.

I’m having issues with my FrSky Receiver and my PixHawk. I get error messages from the PixHawk in QGroundControl about “0 channels detected, PixHawk needs at least 5”.

This happens when I try to use QGroundControl to calibrate my Controller’s joysticks and switches.
This error message is coming in on the Telemetry transmitter connected to the PixHawk.

Sure, the Receiver binds and shows good RSSI signal on the Transmitter/Controller. But my PixHawk can’t understand the message, because of something “special” FrSky does to the serial data stream.
Basically no signal getting through. I have 8 or more channels configured on the Transmitter.