Pixfalcon + px4flow not acquiring position lock in no gps mode

I am trying to get PixFalcon to work together with a px4flow sensor without using a GPS, on TBS discovery frame.

I flashed px4fmu-v2_lpe version 1.7.0 onto the the pixfalcon, using QGroundControl (v 3.2.7) and the latest px4flow firmware on the px4flow sensor. Then I calibrated all the sensors and set the following parameters.

LPE_FUSION : 162 (fuse optical flow, pub agl as lpos down, fuse baro)  SENS_FLOW_ROT : YAW 270 LPE_LAT : 0 LPE_LON : 0 SYS_MC_EST_GROUP : LPE MPC_ALT_MODE : Terrain Following MPC_XY_P : 0.5 MPC_XY_VEL_MAX : 2

I then turned on the power supply. The fmu boots up and the main led is on the slow blue blink pattern (no audible beeps). I then tried to lift up the drone so that the px4flow sensor could initialize and give a postion lock. On a successful position lock, I expect the LED to go to green blinking state (indicating position lock acquired and its ready to be armed). However, it never goes to that state.

I know that optical flow is working correctly, because, when I analyze the flow messages in QGroundControl, the values seem to correctly follow the manual movements. The problem seems to be happening at the time of fusing the optical flow data.

I tried using a pixhawk (instead of pixfalcon) and got the same behavior.

When I try older lpe firmware versions on pixhawk, it was able to get a position lock in no gps mode using px4flow with version 1.4.4, 1.5.1, 1.5.5 (custom build was necessary on 1.5.5, since it doesn't include lpe in the default image) and 1.6.0rc1 (px4fmu-v2_lpe.px4). Staring 1.6.0-rc2 (px4fmu-v2_lpe.px4) it stopped working, the led doesn't transition to blinking green state.

Please note that for each of the trials, the parameters were changed to not use/turn off gps and fuse optical flow and the px4flow firmware was not changed.

I then tried to flash 1.6.0rc1 lpe firmware on pixfalcon but couldn't get it to work, even after multiple calibration attempts. It kept fast flashing red. My guess is this firmware version is not supported on pixfalcon.

What firmware version and settings are recommended to get pixfalcon working with px4flow in no gps mode?
Alternately, can someone point me to source code changes that can be done in the recent version of the firmware to get this to work.


I was able to get this working by setting the parameter