MAVLink shell and Serial connection on Pixhawk 4


I can’t access the MAVLink shell from an Ubuntu VM or a Raspberry Pi via the micro-USB (./Tools/ /dev/ttyACM0) or an FTDI adapter (./Tools/ /dev/ttyUSB0).

The full story goes like this:
I need to establish two serial connections between a Pixhawk 4 and a Raspberry Pi 3B.

For the first connection I have connected an FTDI Adapter to either the TELEM1, TELEM2 or the UART & I2C B port on the Pixhawk to a USB port on the Raspberry Pi.
For the second connection I have connected either TELEM1, TELEM2 or UART & I2C B port of the Pixhawk 4 to the UART GPIO pins on the Raspberry Pi.

I then wanted to test the connections by accessing the MAVLink shell. For the FTDI adapter, I ran
./Tools/ /dev/ttyUSB0 (as the FTDI adapter is mapped to /dev/ttyUSB0 on the Raspberry Pi) on the Pi. I could not access the shell. At that point, accessing the shell via the micro-USB cable worked. Using an Ubuntu VM gave the same result.

Then, I tried to fix it by changing a parameter (which I think was SER_TEL1_BAUD but am not sure) from ‘Auto’ to ‘57600’ using QGroundControl.

After this change, however, I am no longer able to connect the vehicle to QGroundControl and I also can’t access the shell via the micro-USB cable.

I did press the FMU-RESET button and the I/O-RESET button but nothing changed.

I can flash the Pixhawk with the Firmware folder from github with ‘make px4_fmu-v5_default’ though.

Does anyone know why I can’t access the MAVLinkshell?