Parameters randomly reset on Pixhawk 2.1 with PX4 1.10.1


The PX4 parameters including the sensor calibration, radio setting and others randomly got reset on the Pixhawk 2.1 with PX4 1.10.1


  1. Iris+ drone with Pixhawk 2.1 powered through a LiPo battery
  2. PX4 v1.10.1
  3. Raspberry-Pi4 powered through a power bank to USB-C. The Raspberry-Pi4 is connected to Pixhawk on Telemetry port over a USB-UART FTDi chip.

These were the steps taken:

  1. Performed a simple take-off and land mission over MAVROS with a companion computer.
  2. After which I tried to arm the copter manually and it failed.
  3. Connected the FCU to QGroundControl with USB and the error message was ‘Pre-Flight checks failed’ (this is not there in the log! I don’t know why)
  4. Lifted the copter up manually and placed in the floor, tried to arm manually and it armed. (I found this sometimes does the trick, once again don’t know why)
  5. Restarted the FCU, connected to the QGroundControl with a USB and all the parameters were reset (like a fresh pixhwak)


I tried the same steps with another Pixhawk 2.1 and I got the same issue. I have a feeling that this happens when the FCU is connected over USB to QGroundControl while the FCU is already powered with a LiPo battery and connected to the Raspberry-Pi4 over telemetry.
Has someone come across this issue before? If yes, is there any way to avoid this in the future?