Optitrack is streaming the data to ROS but Pixhawk local position is not reflecting it

We are trying to use Optitrack to achieve position hold mode of the Quadrotor, while we use RC to fly it indoors. We are following the following tutorial


We are able to stream data to ROS to the topic mavros/mocap/pose but when we look into the local position from the quadrotor we do not see anything except constant position.

One of the issue that we faced was that we were not able to figure out how to change the LPE_Fusion parameters as stated in above tutorial. LPE_fusion accepts only numbers while tutorial asks us to set some more parameters which we could not find. For example when we are using QgroundControl the tutorial says

“Vision integration is enabled by default in LPE. You can control this using theLPE_FUSION parameter in QGroundControl. Make sure that “fuse vision position” is checked.”

now we cannot find any thing linke “fuse vision position” checkbox in QgroundControl parameters.

Are we missing something here. Please I am new to using Pixhawk and even this platform, forgive my ignorance, but once I learn good amount I will try to participate and contribute more to this platform.

Thanks for the help.


Could you find the parameter “fuse vision position”?

What firmware version do you use?


Thank you for taking interest in the question.
Yes, initially , I could not find that parameter, since in some versions of Qgroundcontrol , this parameter is hidden under the parameter LPE_FUSION. So in that case a suitable value for LPE_FUSION , such as 94 or any other, could make sure that fuse vision position is check.

I am using the firmware with LPE.