Motor Setup/Test Problem(Motors not spinnig)

Greetings to all,

I’m using QGC(4.1.4) and Px4 (newest).

I am working on a new project and I am facing a problem that I have never encountered before.

First of all, I have to start over;
1-) When I arm the device, the motors do not start. First I bring the throttle’s arm to 80% and as soon as the engines start to spin I lower it back so it doesn’t run like crazy.

2-) there is an excessive vibration in the engines. I am attaching the video link; High Vibration at Brushless Motors - YouTube

3-) Although I get no warning on the QGC engine test screen, my engines never start.
There is a very low sound from the ESCs, but it is really low and the motors still do not turn.

Finally, I made a mistake on my first test flight and tried to fly in auto mode and crashed to the ground at a distance of about 1.5 meters from the ground. I think my drop was due to PID because it tumbled and fell while trying to balance itself in auto mode. It’s not my video, but I’m attaching an example video; T960 high vibrations and instability - YouTube


Please do not withhold what you know. Thanks for be interested.
İşleniyor: log_48_2021-10-22-18-28-44.ulg…

Do I understand this correctly that the two motors don’t spin up anymore after you crashed it into the ground?
Quickest assurance would be to switch around a motor that you know is working to rule out defective ESC hardware.
I’m really sorry to say but from afar it really sounds like a case of “I smashed it in the ground and now something doesn’t work right anymore” and believe me we’ve all been there before. :wink:

Hi Cristian,

First of all thank you for your answer but I was completely misunderstood.

All motors and esc are solid. The accident was a minor incident. Actually, I may have misrepresented myself. actually the problem is: the motors vibrate a lot and the motors do not start in the motor test screen. before and after the accident.

note: both motors and esc are factory new

I see so you’re motors vibrate during flight?
Do you mean they produce lots of vibration for the craft (because that’s what they do and would have to be tuned out via PID-tuning) or like are they physically shaking? In which case you’d have to adress that mechanically.

There is a parameter for motor-test as well and you might have to enable that to get em spinning from the test screen.
Motor test might also be not included in your firmware (it can be left out for flash-limitation reasons…).

Gosh I hope I’m not completely off here… ^^
cheers friend.


Have you completely arm your drone (eventually using the GPS module button), before testing with the software ? The drone should be ready to fly.


Unfortunately, there is no obstacle related to Safety Switch. I can arm the engines and they start when I arm them. They do not work in the motor test part and a very low tsss sound is heard from the esc.


the engines physically vibrate, but the problem is; When I start the motors with the radio as if calibrating the esc, there is no vibration, but when I arm and start it through the controller, they vibrate.

Video: High Vibration at Brushless Motors - YouTube

Try reducing your P-gains on the PID tuning tab on all axes.
I find the defaults for any given quadcopter frame preset tend to be too high so wild shaking is the result.
When you arm the PID loop gets active so this sound like a good first thing to try.
If the P’s are at 1 try lowering them to something like 0.6 and see if that resolves the shaking.

Thank you very much for your answer, I will try it right away. I hope it gets resolved.

Hi. I solved the problems and went to the flight test again. The first flight was amazing. Then I started flying again. I went straight ahead and suddenly somersaulted on my way back. I was flying in stabilized mode. I don’t see anything interesting in the log records either. Can you please look?İşleniyor: log_67_2021-11-18-17-12-52.ulg…

How can I add the log file here?