Logging on SD card error

Hi all,

I recently run into some problem with logging on SD card with PX4.
I start the logging in nsh> shell with ‘logger’ command. Sometimes, it works just fine, but almost always I receive this error message:

INFO [logger] logger started (mode=all)
nsh> ERROR [logger] failed creating log root dir: /fs/microsd/log (116)

So far I couldn’t figure out what it depends on if it works or not. Can anyone help me how to get around it?

Additional info that might help:
My flight controller is Holybro Durandal.
To use nsh shell, I tried both QGC and from terminal (ubuntu 18.04) with MAVSDK-Python.
PX4 version is the current master release.
I connect my computer and Durandal via usb serial port.

Thanks in advance for any help!

@Safranek42 what version of PX4 are you using?

@bkueng this is fixed, right?

Apparently not: Intermittent logging failures

Thanks for the fast reply.
@JulianOes I am using the current master version, downloaded about two weeks ago.
@bkueng Thanks, I checked what you linked. I have tried the bench_sd command. First time it showed writing error. When I tried again (several times) I have got this:

ERROR [sd_bench] Can’t open benchmark file /fs/microsd/benchmark.tmp

Might be a board-specific Durandal issue?

Yes it’s definitely a board-specific issue. We have not any reports like that for other boards.

1 Like

Hi,

On the github forum I found a solution that seems to work:


(so far I only tried the comment to solve the logging failures, I will most probably try merrock’s other solutions for formatting issues)

Will it (or any other solution for this) be included in 1.11 stable version? I tried the Beta 2 version and it still has the same problem.