[logger] write failed (28). "No space left on device"

Hi all,

Custom board similar to fmu-v5 used for ground rover, project is based on almost latest px4 master, logger module was not changed.

I wonder what can possibly cause logger to stop logging on SD card with errno 28 (“No space left on device”) while there is a lot of free space (29GB out of 30GB)? It already happens twice after a while - in first run it failed after written 60Mb in another run with 192Mb, both files are corrupted. Both runs was ulogged successfully through usb mavlink where I found out logger error message.

Can it be for example due to sd discontacts on vibrations?

Thanks in advanced for any thoughts.



Be sure to double check your hardware.
Also, try with other Memory cards and/or boards if possible.



What exactly should I check in hardware?
I’ve tried another SD card - logger get failed with same error even after a few minutes.

Have you tried with another board?

No, I don’t have another board right now.

Cause the same thing happened to me and then realized my FCU was problematic.

Could you please disclose details what was the problem? SD card holder, power or what?