Lifting off on windy days

Hello all,

I am having the "Preflight Fail: check Airspeed Cal or Pitot" error very often on windy days. The workaround I do is just yawing 90 degrees the aircraft so that it has side wind at takeoff, which is quite dirty solution especially in stormy days.

I noticed that the preflight airspeed limit is a hard-coded 4 m/s value in airspeedCheck.cpp as following:

	/*
 * Check if airspeed is higher than 4m/s (accepted max) while the vehicle is landed / not flying
 * Negative and positive offsets are considered. Do not check anymore while arming because pitot cover
 * might have been removed.
 */
if (fabsf(airspeed.indicated_airspeed_m_s) > 4.0f && prearm) {
	if (report_fail) {
		mavlink_log_critical(mavlink_log_pub, "Preflight Fail: check Airspeed Cal or Pitot");
	}

	present = true;
	success = false;
	goto out;
}

Wouldn’t it be handy to put a user-accesible variable to set the airspeed limit to arm?

Thanks,
Ozan

Or you can cancel the pre-flight airspeed check by setting the parameters

@xdwgood, thanks for the reply.

Do you mean setting CBRK_AIRSPD_CHK = 162128? Doesn’t it correspond to VTOL without an airspeed sensor?

Does not it disable using airspeed totally?

I did address it in https://github.com/PX4/PX4-Autopilot/pull/14254/files, though it hasn’t been merged yet. I will push more for it, should help that I’m not the only one hitting this problem.
In the PR I introduce a new parameter, COM_ARM_ARSP_EN, which could be set to false to disable a check for max airspeed for takeoff.
Feel free to comment on the PR, this way we could get more attention to get it in faster.

1 Like