Landing gear retract function not working

I need some help with this. I’m converting a hexacopter from Ardupilot running on a Pixhawk 2.1 to PX4 running on a Pixhawk 4. With the original setup, the retractable LG is on channel 7, and it works fine. Although I changed both the flight controller and firmware, the hardware setup is the same. However after the conversion to PX4/Pixhawk 4, the retract function does not work. I used the AUX Passthrough channels setup. I’ve set various params but nothing I’ve tried solves the issue.

This is what I have now:
RC_MAP_AUX1 set to Channel 7
RC_MAP_GEAR_SW set to Channel 7
PWM_MAIN_MAX7 set to 1900
PWM_MAIN_Min7 set to 1100
PWM_MAIN_FAIL7 set to 1100

How can I debug this issue? Are there any other params that need to be set?


Problem solved.

It turns out that with the Pixhawk 4, you need to use the FMU PWM OUT ports for retracts, servos, etc. The I/O PWM OUT connections are evidently used only for motors. When I connected the retracts unit to FMU PWM OUT slot 1, the retracts worked from channel 7 on the RC Tx.