Issue lunching jmavsim flight simulator

Hello guys,

I’ve got an issue with the flight simulator jmavsin, and would like to be help on it.

I follow this tutorial:

Everything looks fine, but I first launch I get a message: [simulator] Waiting for simulator to connect on UDP port 14560

I open this port on Unbuntu and another one (TCP) (after trying multiple things found on internet), and then I was able to launch the simulator.

But now, i cannot make the drone takeoff, by tapping commander takeoff.
The guy in his tutorial have a “pxh >” that I don’t have and I don’t know why.

I tried also on windows (following the windows setup tutorial) and same issue, I canno’t commander takeoff.

I don’t know what I’m missing. If you can help me it would be grate.

Ubuntu version: 20.04.2 LTS

I’m a beginner at px4 and ubuntu stuff, so sorry if I miss something obvious.

Thanks for your future help.

root@FATHER:/home/alex/Firmware# make px4_sitl_default jmavsim

[0/1] cd /home/alex/Firmware/build/px4…e/alex/Firmware/build/px4_sitl_default
sitl_bin: /home/alex/Firmware/build/px4_sitl_default/bin/px4
debugger: none
program: jmavsim
model: none
world: none
src_path: /home/alex/Firmware
build_path: /home/alex/Firmware/build/px4_sitl_default
empty model, setting iris as default
SITL COMMAND: “/home/alex/Firmware/build/px4_sitl_default/bin/px4” “/home/alex/Firmware/build/px4_sitl_default”/etc -s etc/init.d-posix/rcS -t “/home/alex/Firmware”/test_data
INFO [px4] Creating symlink /home/alex/Firmware/build/px4_sitl_default/etc → /home/alex/Firmware/build/px4_sitl_default/tmp/rootfs/etc

| ___ \ \ \ / / / |
| |/ / \ V / / /| |
| __/ / \ / /
| |
| | / /^\ \ ___ |
_| / / |_/

px4 starting.

INFO [px4] Calling startup script: /bin/sh etc/init.d-posix/rcS 0
Info: found model autostart file as SYS_AUTOSTART=10016
INFO [param] selected parameter default file eeprom/parameters_10016
[param] parameter file not found, creating eeprom/parameters_10016
SYS_AUTOCONFIG: curr: 0 → new: 1
etc/init.d-posix/rcS: 108: simulator_udp_port: not found
SYS_AUTOSTART: curr: 0 → new: 10016
CAL_ACC0_ID: curr: 0 → new: 1310988
CAL_GYRO0_ID: curr: 0 → new: 1310988
CAL_ACC1_ID: curr: 0 → new: 1310996
CAL_GYRO1_ID: curr: 0 → new: 1310996
CAL_ACC2_ID: curr: 0 → new: 1311004
CAL_GYRO2_ID: curr: 0 → new: 1311004
CAL_MAG0_ID: curr: 0 → new: 197388
CAL_MAG1_ID: curr: 0 → new: 197644
SENS_BOARD_X_OFF: curr: 0.0000 → new: 0.0000
SENS_DPRES_OFF: curr: 0.0000 → new: 0.0010

  • SYS_AUTOCONFIG: curr: 1 → new: 0
    IMU_INTEG_RATE: curr: 200 → new: 250
    INFO [simulator] Waiting for simulator to connect on UDP port 14560
    Buildfile: /home/alex/Firmware/Tools/jMAVSim/build.xml





Total time: 0 seconds
Options parsed, starting Sim.
Starting GUI…
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by (rsrc:j3dcore.jar) to method sun.awt.AppContext.getAppContext()
WARNING: Please consider reporting this to the maintainers of
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
commander takeoff

Ok guys ! It’s finally working. I just install Ubuntu 18 instead of 20.
I encountered the same issue on Windows 10.
Hope it will help someone one day !
Have a great day