First Build (Using the jMAVSim Simulator) Error

Hello,

I’m a new user with PX4 and I followed the tutorial in the site. When I tried to run the simulation with jMAVsim with the following command :
make px4_sitl jmavsim
This error occurs :


– PX4 version: v1.10.0-beta4-382-gf2d08df777
– PX4 config file: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/boards/px4/sitl/default.cmake
– PX4 config: px4_sitl_default
– PX4 platform: posix
– PX4 lockstep: enabled
– cmake build type: RelWithDebInfo
– The CXX compiler identification is GNU 7.4.0
– The C compiler identification is GNU 7.4.0
– The ASM compiler identification is GNU
– Found assembler: /usr/bin/cc
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Detecting CXX compile features
– Detecting CXX compile features - done
– Check for working C compiler: /usr/bin/cc
– Check for working C compiler: /usr/bin/cc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Detecting C compile features
– Detecting C compile features - done
– ccache enabled (export CCACHE_DISABLE=1 to disable)
– Found PythonInterp: /usr/bin/python (found version “2.7.15”)
– Found PY_jinja2: /usr/local/lib/python2.7/dist-packages/jinja2
– PX4 ECL: Very lightweight Estimation & Control Library v1.9.0-rc1-96-g6b5f011
– Configuring done
– Generating done
– Build files have been written to: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/build/px4_sitl_default
[17/719] git submodule src/drivers/gps/devices
[19/719] git submodule src/lib/ecl
[194/719] git submodule mavlink/include/mavlink/v2.0
[201/719] git submodule Tools/jMAVSim
[718/719] cd /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/b…emence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/build/px4_sitl_default
SITL ARGS
sitl_bin: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/build/px4_sitl_default/bin/px4
debugger: none
program: jmavsim
model: none
src_path: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware
build_path: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/build/px4_sitl_default
empty model, setting iris as default
SITL COMMAND: “/home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/build/px4_sitl_default/bin/px4” “/home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware”/ROMFS/px4fmu_common -s etc/init.d-posix/rcS -t “/home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware”/test_data
INFO [px4] Creating symlink /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/ROMFS/px4fmu_common -> /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/build/px4_sitl_default/tmp/rootfs/etc
0 WARNING: setRealtimeSched failed (not run as root?)


| ___ \ \ \ / / / |
| |/ / \ V / / /| |
| __/ / \ / /
| |
| | / /^\ \ ___ |
_| / / |_/

px4 starting.

INFO [px4] Calling startup script: /bin/sh etc/init.d-posix/rcS 0
INFO [param] selected parameter default file eeprom/parameters_10016
[param] parameter file not found, creating eeprom/parameters_10016
SYS_AUTOCONFIG: curr: 0 -> new: 1

  • SYS_AUTOSTART: curr: 0 -> new: 10016
    BAT_N_CELLS: curr: 0 -> new: 3
    CAL_ACC0_ID: curr: 0 -> new: 1311244
    CAL_ACC_PRIME: curr: 0 -> new: 1311244
    CAL_GYRO0_ID: curr: 0 -> new: 2294028
    CAL_GYRO_PRIME: curr: 0 -> new: 2294028
    CAL_MAG0_ID: curr: 0 -> new: 197388
    CAL_MAG_PRIME: curr: 0 -> new: 197388
    CAL_BARO_PRIME: curr: 0 -> new: 6620172
    COM_DISARM_LAND: curr: 2.0000 -> new: 0.1000
    COM_OBL_ACT: curr: 0 -> new: 2
    COM_OF_LOSS_T: curr: 0.0000 -> new: 5.0000
    COM_RC_IN_MODE: curr: 0 -> new: 1
    EKF2_ANGERR_INIT: curr: 0.1000 -> new: 0.0100
    EKF2_GBIAS_INIT: curr: 0.1000 -> new: 0.0100
    EKF2_REQ_GPS_H: curr: 10.0000 -> new: 0.5000
    MC_PITCH_P: curr: 6.5000 -> new: 6.0000
    MC_PITCHRATE_P: curr: 0.1500 -> new: 0.2000
    MC_ROLL_P: curr: 6.5000 -> new: 6.0000
    MC_ROLLRATE_P: curr: 0.1500 -> new: 0.2000
    MPC_HOLD_MAX_Z: curr: 0.6000 -> new: 2.0000
    MPC_Z_VEL_I: curr: 0.1000 -> new: 0.1500
    MPC_Z_VEL_P: curr: 0.2000 -> new: 0.6000
    MPC_XY_P: curr: 0.9500 -> new: 0.8000
    MPC_XY_VEL_P: curr: 0.0900 -> new: 0.2000
    MPC_XY_VEL_D: curr: 0.0100 -> new: 0.0160
    MPC_JERK_MIN: curr: 8.0000 -> new: 10.0000
    MPC_ACC_HOR_MAX: curr: 5.0000 -> new: 3.0000
    NAV_ACC_RAD: curr: 10.0000 -> new: 2.0000
    NAV_DLL_ACT: curr: 0 -> new: 2
    RTL_DESCEND_ALT: curr: 30.0000 -> new: 5.0000
    RTL_LAND_DELAY: curr: -1.0000 -> new: 5.0000
    RTL_RETURN_ALT: curr: 60.0000 -> new: 30.0000
    SDLOG_MODE: curr: 0 -> new: 1
    SDLOG_PROFILE: curr: 3 -> new: 131
    SDLOG_DIRS_MAX: curr: 0 -> new: 7
    SENS_BOARD_X_OFF: curr: 0.0000 -> new: 0.0000
    SENS_DPRES_OFF: curr: 0.0000 -> new: 0.0010
    TRIG_INTERFACE: curr: 4 -> new: 3
  • RTL_DESCEND_ALT: curr: 5.0000 -> new: 10.0000
  • RTL_LAND_DELAY: curr: 5.0000 -> new: 0.0000
    PWM_MAX: curr: 2000 -> new: 1950
    PWM_MIN: curr: 1000 -> new: 1075
  • SYS_AUTOCONFIG: curr: 1 -> new: 0
    INFO [dataman] Unknown restart, data manager file ‘./dataman’ size is 11798680 bytes
    INFO [simulator] Waiting for simulator to connect on TCP port 4560
    INFO [init] Mixer: etc/mixers/quad_w.main.mix on /dev/pwm_output0
    INFO [mavlink] mode: Normal, data rate: 4000000 B/s on udp port 14570 remote port 14550
    INFO [mavlink] mode: Onboard, data rate: 4000000 B/s on udp port 14580 remote port 14540
    INFO [logger] logger started (mode=all)
    INFO [logger] Start file log (type: full)
    INFO [logger] Opened full log file: ./log/2019-11-28/17_30_06.ulg
    INFO [mavlink] MAVLink only on localhost (set param MAV_BROADCAST = 1 to enable network)
    INFO [px4] Startup script returned successfully
    pxh> Buildfile: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/Tools/jMAVSim/build.xml

make_dirs:
[mkdir] Created dir: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/Tools/jMAVSim/out/production/jMAVSim

compile:
[javac] Compiling 76 source files to /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/Tools/jMAVSim/out/production/jMAVSim

create_run_jar:
[jar] Building jar: /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/Tools/jMAVSim/out/production/jmavsim_run.jar

copy_res:
[copy] Copying 17 files to /home/clemence/_Projets/Challenge_NAE/PIX4/GIT/Firmware/Tools/jMAVSim/out/production

BUILD SUCCESSFUL
Total time: 21 seconds
Options parsed, starting Sim.
Starting GUI…
3D [dev] 1.6.0-pre12-daily-experimental daily

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by javax.media.j3d.JoglPipeline (rsrc:j3dcore.jar) to method sun.awt.AppContext.getAppContext()
WARNING: Please consider reporting this to the maintainers of javax.media.j3d.JoglPipeline
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Inconsistency detected by ld.so: dl-lookup.c: 111: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)’ failed!

pxh> commander takeoff
ERROR [commander] rejecting takeoff, no position lock yet. Please retry…
Command ‘commander’ failed, returned 1.


I don’t know how to solve this problem. Is someone have a solution ?
Thank you.