Impossible to publish for multi-drone simulation with ROS2 & Gazebo

Hello ! I am trying to launch a multi-drone simulation (model : x500) that I want to control individualy. For that, I am using ROS2 humble, Gazebo and PX4 Autopilot v1.14.0. Until now, I have been doing simulations with a single drone which is working perfectly. I run the PX4 SITL simulation and the Micro XRCE-DDS Agent with the following commands :

make px4_sitl_default
MicroXRCEAgent udp4 -p 8888

Then, I tried calling the commands advised in this page. At first, I am trying with just one drone (px4 -i 1) to see if when I change all the topics in my nodes, the drone acts similarly than when there were no id. The running commands are changed by the following :

PX4_SYS_AUTOSTART=4001 PX4_GZ_MODEL=x500 ./build/px4_sitl_default/bin/px4 -i 1
MicroXRCEAgent udp4 -p 8888

By doing that I can see that there are no problems creating the topics, I can see the drone created in Gazebo and it seems that subscribing is working, however, when I ask to publish (on VehicleCommand for instance) to arm the drone nothing happens.

I might be missing something, also I am pretty new with all that, so if anyone knows how to solve that issue, please let me know, I would greatly appreciate it. Thank you !

Hi @Gaetan15
Did you read this? Multi-Vehicle Simulation with ROS 2 | PX4 User Guide (main)

you probably have the target_system non properly configured