I was only able to establish a connection to the PX4 "mission computer" in simulation

I want to use px4 with mission computer in PX4 software. While working in the simulation environment, it did not work even if I inserted the px4 card and followed the steps.
Micro REAgent udp4 -p 8888 command is running for simulation program. I can see the data by doing ros2 topic list but even if I inserted the normal px4 card and installed the software, even if I listened to the connection I connected to the telem2 part from the command sudo MicroXRCEAgent serial --dev /dev/AMA0 -b 921600 it did not work.
Do I need to open something in the px4 software as an extra?
Do I need to make any changes from the make px4_fmu-v5 config command?

I set the UXRCE_DDS_CFG parameter in the QGC section “tool setup → Parameters → UXRCE-DDS client” to telem2. I disconnected the QGC and connected it to my computer via FTDI cable on the telem2 part and it worked.

When using FTDI and testing directly via the USB port, it worked. However, at 921,600 baudrate on the UART port, it didn’t work. Communication was established over UART at baudrate values below 500,000, but the issue of topics constantly refreshing, repeatedly disconnecting and reconnecting persists, and I haven’t been able to resolve this problem (Tested on Jetson Nano)

sudo MicroXRCEAgent serial --dev /dev/ttyTHS2 -b 460800