How do you configure a Pixhawk 5X's ethernet interface with a static IP address?

Hi,

I’m trying to configure the Ethernet interface on my Pixhawk 5X (v1.12.3) to use a static IP address, to communicate with my companion computer. However, the lack of available documentation is hampering my efforts, and was wondering if there’s a guide / tutorial on how to configure this.

Thanks,
Donald

Playing around, I’m able to ping between the two by configuring the following:

  • Setting MAV_1_CONFIG to Ethernet and exposing the following two parameters.
  • Leaving MAV_1_REMOTE_PRT and MAV_1_UDP_PRT as its default value of 0
  • Setting my companion computer to use a 192.168.0.X address
    • (The Pixhawk defaults to a 192.168.0.X address by default)

However, there are still problems:

  • This requires changing the companion computer from its original address of 10.1.1.X, which breaks compatibility with the rest of the system. This is the topology I’m aiming for:

image

  • No MAVLink data is emitted from the Pixhawk despite the successful ping. The only thing coming over to and from the interface are DNS queries

  • The MAVLink interface on the Pixhawk reports no successful TX, only TXError

3 (2)

Additionally would it be possible to connect both the companion computer and QGC to use the same Ethernet network, as depicted in the topology above?

Rather then having a serial line dedicated for QGC, and an Ethernet line dedicated for the companion computer.