Holybro ESC issue on `master`

Jacob Dahl 5:55 PM
Migrating issue from slack

I flashed master … and now my motors are getting driven like Flashing back to 1.9.2 does not fix the issue…here’s the full chain of events.

  1. Flash 1.9.2 , set s500_holybro airframe, fly around great.
  2. Flash master , reset params to default, reset airframe to s500_holybro .
  3. Attempt to arm/fly, drone stays on ground (at max throttle) and motors are making a disturbing sound
  4. Fly two separate airframes with Pixhawk4 on master … they fly great…
  5. Reflash my S500 with 1.9.2 and reset params/airframe again… attempt to arm/fly and same terrible motor behavior.Log from first great flight with 1.9.2 https://review.px4.io/plot_app?log=12fc1bfb-661e-4dd1-9794-5258427de23d
    Log from attempting to fly with master , (I had someone hold it while I played with the sticks) https://review.px4.io/plot_app?log=8232b19b-8654-4646-b41e-91993091d092
    Log from attempting to fly after flashing back to 1.9.2 https://review.px4.io/plot_app?log=0a4a98c2-2916-487b-9fa1-71215f66d2e8Something is amiss here and I can’t figure it out… whatever the differences are clearly they’re not being captured in the s500_holybro airframe config. It seems like the thing “flew great” after being shipped to m. My hunch is a full parameter reset wiped something out and I am not sure what…


So I had @dagar help me with this, and I got it fixed. By fiddling with the PWM_RATE (set to something other than 400, power cycles, set back to 400, power cycle) I was able to get the ESCs functioning again. A theory is the ESCs are getting stuck in the wrong mode. I went ahead and reproduced this, it is as easy as flashing master via the CLI make px4_fmu-v5_default . No amount of fiddling with the PWM_RATE settings restores proper functionality. I flashed back to 1.9.2 again … this time no fiddling with PWM_RATE was required, they justed worked as expected. Could the flashing of the px4io be screwing with the ESCs

Hey Jacob, Thanks for the update. So basically it’s solved with flashing firmware?

Yes. master does not work still. v1.9.2 works fine. I scoped the motor outputs during boot and I am seeing some differences.



As you can see, there are 5 pulses of 900us pulse width spaced at 20ms on v1.9.2, they do not appear on master. I have no idea if these pulses mean anything to an ESC, this is the only difference I was able to find. During flashing of firmware, the PWM stays at 900us and 400hz during the entire flashing process for both firmware versions. It would be good to get someone to work on this, as I currently cannot fly master on my development platform, which is severely limiting me