Hexarotor takes circles and crashes in position mode


I am using a custom hexarotor airframe, for which I have been tuning the PID controller. After tuning the PID controller on our Test frame I copied the exact same parameters on our production airframe (Production airframe and Test airframe are similar with same dimensions and mass, the only difference is the location of the pixhawk and gps on the airframe but the orientations are same). When I took off in position mode with the new frame the flight was very stable. When I centered my joysticks, the drone started taking circles about 3-4 meter diameter and started a decent taking circles. It was as if the drone was revolving around a fixed point. I tried to control it but eventually the drone crashed. I tried changing the PID gains but I face similar problem again and again. Is this because of my PID gains or are the sensors giving me wrong reading? I also checked gyroscope and compass reading on QgroundControl but it looks good. This picture will explain the flight pattern more correctly.

Thank you

That’s definitely a compass problem, this type of issue is commonly referred to as a “toilet bolw”. Badly oriented compasses, a bad calibration of them or they are affected by interferences due to the current consumed by the motors. Check the orientations. Re-calibrate the compasses. And also make sure the external compass is clear of possible interference.

I hope this one helps you.

Thanks for the suggestion. So I re-calibrated all sensors and then tried it again. The first attempt was good but during the second attempt the uav again started a toilet bowl. Why is this happening ? Should I try a different GPS module?

Hi @rajas_chitanvis @AngelAlbeniz @bresch
I am facing the exact same problem with my Hexacopter. I am using Here2.
pls let me know if you have solved the problem !!!

What flight controller and firmware version are you using?

Hi @rajas_chitanvis
Thanks for the replay
Its cube fmuv_3 with 1.11.1 stable version

There is an on-going issue on github take a look at this : https://github.com/PX4/PX4-Autopilot/issues/16035. You should be able to fly with 1.10.1 stable version.

Thanks @rajas_chitanvis
I ll check and update.