GBD __lll_lock_wait_private (futex=0x7ffff451ed18) at lowlevellock.c:35


I am following the directions for GDB debugging here: link to PX4 docs

However, every time I start the simulator with make px4_sitl_default gazebo___gdb
I always get the following error

Thread 62 "px4" received signal SIG32, Real-time event 32.
[Switching to Thread 0x7ffff4584b80 (LWP 3965)]
__lll_lock_wait_private (futex=0x7ffff4585198) at lowlevellock.c:35
35	in lowlevellock.c
(gdb) c
[Thread 0x7ffff4584b80 (LWP 3965) exited]
INFO  [dataman] data manager file './dataman' size is 7866640 bytes
[Thread 0x7fffeffff700 (LWP 3964) exited]
[New Thread 0x7fffeffff700 (LWP 4117)]
[Thread 0x7fffeffff700 (LWP 4117) exited]
[New Thread 0x7fffeffff700 (LWP 4120)]
[Thread 0x7fffeffff700 (LWP 4120) exited]
[New Thread 0x7fffeffff700 (LWP 4122)]
[Thread 0x7fffeffff700 (LWP 4122) exited]
PX4 SIM HOST: localhost
[New Thread 0x7fffeffff700 (LWP 4124)]
[New Thread 0x7ffff4570700 (LWP 4125)]
[New Thread 0x7fffeeffd700 (LWP 4126)]

Thread 68 "px4" received signal SIG32, Real-time event 32.
[Switching to Thread 0x7ffff4570700 (LWP 4125)]
__lll_lock_wait_private (futex=0x7ffff4570d18) at lowlevellock.c:35
35	in lowlevellock.c

So the program keeps pausing on __lll_lock_wait_private, which makes debugging very hard.
I was wondering if I am missing something

What I have tried

  1. make clean and rebuild with gdb command
  2. adding the following to gdbinit
add-auto-load-safe-path /home/atlas/px4/rover/PX4-Autopilot/build/px4_sitl_default/rootfs/.gdbinit
  1. Tried to turn off optimizations with
export PX4_NO_OPTIMIZATION='px4;^modules__uORB;^modules__systemlib$'

Seems like this is a good post as to what is going on

lib is there, but files are not.

Installing glib source

Did not make a difference. Still happening