Flight Review: HTTP Error 400: Invalid File

Hello All,
I am using a PX4 v1.7. I haven’t been able to do log analysis. I downloaded the log file with QGroundControl. It has time stamp in the name and extension is .ulg.
I have tried to follow different tools with no luck so far.

Flight Review: gives the Error 400: Invalid file. I tried with 3 different files but all gave the same error.

Pyulog: Gives an error about header of the file being wrong

PX4Tools: It gives the same error with pyulog. It is using pyulog to read file anyway AFAIK

Here is one of the log files.

Any help would be greatly appreciated.

Sounds like the current tools are not compatible with PX4 v1.7. To be fair, that’s quite old. I would try to go back in the git history of these tools, so checkout a version with a similar date of v1.7 and see if it’s possible to use it.

Thanks, it is pretty old.
It works though, only the log analysis has been problematic so far. When I try to directly download from the sd card the logfile extension is actually px4log. It actually has the same file size etc. It looks to be the same file.
I thought trying to analyze it as a px4log file, with older tools would work. But no luck so far