Can't get a working log file out of gazebo simulations

I’ve tried legacy gazebo installation, gazeob-classic, and the updated gazebo simulation instructions, but for all of them (on both Ubuntu 20.04 and 22.04) the following happens when I try to extract data from a log file:

  1. I start the simulation with whatever instructions are listed on the following pages:
    Gazebo Simulation Main Page/ Gazebo Simulation (most recent?) Main Page / Gazebo Classic Main Page

  2. I open qgroundcontrol to make sure that my controller is working, and to make sure I’ve got the parameters set to record the log files. I just recently changed SYS_HITL to SIH enabled to see if that would make a difference, but this didn’t work.

  3. Perform a simple flight

  4. Download the log file from the “Analyze Tools” tab of qgc. I’ve also tried copying the log file from /PX4-Autopilot/build/px4_sitl_default/rootfs/log, but the same things happen

  5. Open MATLAB, and use the ulogreader function to read the extracted ulog file. I know this works, as I have previous log files which I can read, but the for the most recent gazebo logs, I get the following output:

When trying to import the data directly, I get the following:

But when using the ulog flight review tool, it seems to work:

Alternatively, with a log file that I know the matlab function works with, from an older version of px4 and gazebo (~Summer 2022, not sure exact version numbers):

Can someone point me in the right direction regarding what I need to change to get the log files to properly output their data in matlab?

Thank you in advance.

UPDATE: It seems like this is just a Matlab issue. The default ulogreader function hasn’t been updated to account for whatever changes happened to ulog files between when I last successfully used it in 2022 and now. Moving on to using pyulog to read/convert ulogs to csv files for future work. Thanks!