Fixed Wing Control Integral Gain not working? [resolved]

Hi,

I am doing some testing on the autopilot in the lab before flying.

So the aircraft is sitting on the table, I put the aircraft to stabilized flight mode and FW_P_TC > 0.

If FW_PR_P > 0 (pitchrate gain), when i tilt the aircraft in pitch, the elevators responds. So the proportional gain loop is working

However, if I set FW_PR_P=0 and FW_PR_I > 0, the elevator doesn’t respond when i tilt the aircraft. This suggest the integral control loop is not working,

I have looked through the code fw_att_control.cpp and no where suggest the integrator is locked/disabled.

Anyone faces the same issue?

This is PX4 firmware v1.4.1

They’re reset until the vehicle is no longer landed. https://github.com/PX4/Firmware/blob/master/src/modules/fw_att_control/fw_att_control_main.cpp#L1046

That explains much. Thanks @dagar

On a side note, is it possible to disable the land detector to test the integral loop on the bench?

Ziyang

Try blowing into the pitot tube or significantly reducing the parameters for the sake of testing and then walking around.
https://dev.px4.io/en/advanced/parameter_reference.html#land-detector

Unfortunately, the UAV is a 6m/10kg research platform and a little unwieldy to walk around with. lol

I could blow the pitot tube to “initiate” takeoff but very quickly it will revert back to “landed” state even with small landing detector parameters.

I guess i could modify the c++ code and comment out the reset_integrator portion, but that’s the last resort.

Ziyang

It might be worth adding a command line option to force the land detector for the sake of testing.

Thanks @dagar. I will look into that