Factor reset the Pixhawk mini?

Hi everyone,

I tried to flash the Pixhawk mini by using the command:
make px4fmu-v2_default upload
then during the flashing I realized the Pixhawk mini must be flashed with V3, so I unplugged the USB cable.

I tried then the command:
make px4fmu-v3_default upload
Erase goes to 100% but Program get stuck for ever (at different percentage). I also tried to flash it from QGroundControl but the same problem happens. I also tried to press the reset button on the Pixhawk mini.

So my question is: Is it possible to factor reset the Pixhawk mini (or directly the STM32 processor) ?



OK so I notice by typing the command:
make px4fmu-v3_default upload
the percentage of the “program” phase got stuck higher and higher. So I type this command several times and it ended up solving the problem :open_mouth:

I hope this can help


I still have this problem.
Is it possible to update the Bootloader of the Pixhawk mini ?
I noticed it is possible for the Pixhawk:



On the file ‘bootlog.txt’ on the Pixhawk mini SD card, I got the error:
ERROR [init] Failed loading mixer: /etc/mixers/AERT.main.mix

I am using Ubuntu 16.04 LTS, and PX4 VERSION: v1.7.0-rc1-2-ge9e6634