ESP8266-ESP201 Issue

Hi, I bought ESP8266-ESP201 module to use as a AP mode, I flash module which is 1.1.1.bin from github, then I connect module to TELEM2 port and these are my parameters:
MAV_1_RATE is 921600
MAV_1_MODE is NORMAL ( also tried onboard but nothing changed)
SER_TEL2_BAUD is 921600
and I don’t know is there any parameter has to be changed.
Then I connect to my controller TELEM2 port my module as
Tx to Rx
Rx to Tx
VCC + 26 ohm to VCC ( my controller is not providing implemented voltage level that’s why I connect resistor)
I connect lipo through the PMB’s PWR2 to POWER2 port of controller.
my computer acts as a ground station I cannot see my module as a wifi network so I cannot connect controller to QGC.
In Arduino I run some codes to set the AP mode and I can connect my phone, PC to that module.
In the first connection I could go then in the other trials I couldn’t.
Also,I read some of the articles about ESP8266 saying that default mode is STA, so I understand that when I connect my module to controller it always acts as a STA and I cannot change it as AP (Access Point).
I am searching about it for days… I couldn’t find any solution and also I didn’t see any issue related to mine in discuss forum that’s why I opened topic.
Could you help me in that case.
Thanks in advance.

Read this:

I made it already but it didn’t work.

Have you been here:

I would ask there as they will know much better.

That could be helpful, I will check it tomorrow, thanks a lot!

If you have any other idea, I am willing to listen it. Have a nice day or goodnight !

Now, still I cannot solve it, and here is my progress and failure step by step:

  1. first I upload the firmware (in the both github and bins lastly I repeated from bins)
    here is the terminal output:
~/Downloads$ --baud 921600 --port /dev/ttyUSB0 write_flash 0x00000 firmware-1.2.2.bin v3.2
Serial port /dev/ttyUSB0
Detecting chip type... Unsupported detection protocol, switching and trying again...
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: 84:f3:eb:4b:3b:09
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 921600
Configuring flash size...
Flash will be erased from 0x00000000 to 0x00051fff...
Compressed 332768 bytes to 232984...
Wrote 332768 bytes (232984 compressed) at 0x00000000 in 3.3 seconds (effective 805.9 kbit/s)...
Hash of data verified.

Hard resetting via RTS pin...

then I connect it to Arduino with that code:

#include <ESP8266WiFi.h>

IPAddress local_IP(192,168,4,1);
IPAddress gateway(192,168,4,9);
IPAddress subnet(255,255,255,0);

void setup()

  Serial.print("Setting soft-AP configuration ... ");
  Serial.println(WiFi.softAPConfig(local_IP, gateway, subnet) ? "Ready" : "Failed!");

  Serial.print("Setting soft-AP ... ");
  Serial.println(WiFi.softAP("PixRacer","pixracer") ? "Ready" : "Failed!");

  Serial.print("Soft-AP IP address = ");

void loop() {}

then arduino terminal output was:

Executable segment sizes:
ICACHE : 32768           - flash instruction cache 
IROM   : 238872          - code in flash         (default or ICACHE_FLASH_ATTR) 
IRAM   : 26729   / 32768 - code in IRAM          (IRAM_ATTR, ISRs...) 
DATA   : 1496  )         - initialized variables (global, static) in RAM/HEAP 
RODATA : 1008  ) / 81920 - constants             (global, static) in RAM/HEAP 
BSS    : 25688 )         - zeroed variables      (global, static) in RAM/HEAP 
Sketch uses 268105 bytes (27%) of program storage space. Maximum is 958448 bytes.
Global variables use 28192 bytes (34%) of dynamic memory, leaving 53728 bytes for local variables. Maximum is 81920 bytes. v3.0
Serial port /dev/ttyUSB0
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: 84:f3:eb:4b:3b:09
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 460800
Configuring flash size...
Auto-detected Flash size: 512KB
Flash params set to 0x0300
Compressed 272256 bytes to 199853...
Writing at 0x00000000... (7 %)
Writing at 0x00004000... (15 %)
Writing at 0x00008000... (23 %)
Writing at 0x0000c000... (30 %)
Writing at 0x00010000... (38 %)
Writing at 0x00014000... (46 %)
Writing at 0x00018000... (53 %)
Writing at 0x0001c000... (61 %)
Writing at 0x00020000... (69 %)
Writing at 0x00024000... (76 %)
Writing at 0x00028000... (84 %)
Writing at 0x0002c000... (92 %)
Writing at 0x00030000... (100 %)
Wrote 272256 bytes (199853 compressed) at 0x00000000 in 4.6 seconds (effective 471.5 kbit/s)...
Hash of data verified.

Hard resetting via RTS pin...

I see that baudrate is changing in arduino but I need it in 921600, and esptool versions are different and I didn’t recognize any other changes in Arduino.
in serial monitor I got :

Setting soft-AP configuration ... Ready
Setting soft-AP ... Ready
Soft-AP IP address =

then I connected to module:

but when I try to go I didn’t, only once I reached that DNS then I never.
I connected ESP201 to controller as I mentioned above module don’t act in AP mode that’s why I cannot use right now.
Is there any adive could you give me? Or is there anything I am missing?
Thanks in advance.

If you see ‘PixRacer’ as AP, it should work. So open and change it to your wifi as client, adjusting ports. Then, connect as UDP with that port.

Note that in this way you can have several vehicles with this ESP8266, and connect to them simultaneously easily with different ports.

I cannot open

Simply use any wifi device, supply the ESP8266-ESP201, and connect to ‘PixRacer’.

What do u mean by supply?

+5V GND on its marked pins.

module’s GPIO pins are only applicable with 5V

Replay: take an independent +5V supply, supply the ESP8266-ESP201, and wait till you see ‘ArduPilot’ wifi. Forget the FC and everything else by now.

I cant understand you , did you read my post? I have already did most of the steps. And I always got the same result, if you mention something could you be a little clear?

Replay: forget the FC, forget what you have done, move just the ESP8266-ESP201 to an empty room, get a +5V/GND supply, get a laptop and turn off your wifi.

Supply the ESP8266-ESP201 with the +5V supply (+5V to +5V (red) and GND to GND (black)), wait a few minutes, see if you connect the wifi laptop to ‘ArduPilot’. If so, open and adjust ESP8266-ESP201 parameters. If no connection, reprogram it.

and this is my ping outputs from terminal:

~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=9 ttl=255 time=66.1 ms
64 bytes from icmp_seq=10 ttl=255 time=99.9 ms
64 bytes from icmp_seq=19 ttl=255 time=5.11 ms
64 bytes from icmp_seq=20 ttl=255 time=2.71 ms
64 bytes from icmp_seq=21 ttl=255 time=13.4 ms
64 bytes from icmp_seq=22 ttl=255 time=2.09 ms
64 bytes from icmp_seq=23 ttl=255 time=2.59 ms
64 bytes from icmp_seq=24 ttl=255 time=1.30 ms
64 bytes from icmp_seq=25 ttl=255 time=1.77 ms
64 bytes from icmp_seq=26 ttl=255 time=34.9 ms
64 bytes from icmp_seq=27 ttl=255 time=1.94 ms
64 bytes from icmp_seq=28 ttl=255 time=5.84 ms
64 bytes from icmp_seq=29 ttl=255 time=1.84 ms
64 bytes from icmp_seq=30 ttl=255 time=8.46 ms
64 bytes from icmp_seq=31 ttl=255 time=1.66 ms
64 bytes from icmp_seq=32 ttl=255 time=2.05 ms
64 bytes from icmp_seq=33 ttl=255 time=39.9 ms
64 bytes from icmp_seq=34 ttl=255 time=28.8 ms
64 bytes from icmp_seq=35 ttl=255 time=29.2 ms
64 bytes from icmp_seq=36 ttl=255 time=1.65 ms
64 bytes from icmp_seq=37 ttl=255 time=4.67 ms
64 bytes from icmp_seq=38 ttl=255 time=2.21 ms
64 bytes from icmp_seq=39 ttl=255 time=23.1 ms
64 bytes from icmp_seq=40 ttl=255 time=19.6 ms
64 bytes from icmp_seq=41 ttl=255 time=1.81 ms
64 bytes from icmp_seq=42 ttl=255 time=3.36 ms
64 bytes from icmp_seq=43 ttl=255 time=3.05 ms
64 bytes from icmp_seq=44 ttl=255 time=7.69 ms
--- ping statistics ---
45 packets transmitted, 28 received, 37.7778% packet loss, time 44403ms
rtt min/avg/max/mdev = 1.301/14.885/99.947/22.383 ms

I re upload and build the firmware then I connected Durandal with ESP201 with
5V+26ohm to ESP’s VCC
RX to TX
TX to RX
but I never see theblue led blinking, and I never connect to ESP module with AP mode I guess it is not passing that mode.
How Can I fix this?
When I run some code in Arduino I can set AP mode but I cannot visit

When I open firmware source files from mavesp8266/src folder I saw that some source files cannot be included, maybe the error cause from that.

first error: #include errors detected. Please update your includePath. Squiggles are disabled for this translation unit (/home/tugbakara/mavesp8266/src/main.cpp).
second: cannot open source file “ESP8266WiFi.h” (dependency of “mavesp8266.h”)
third: cannot open source file “ESP8266mDNS.h”
and for the other files same errors are happening.
If you have an idea please share with me, have a nice day

I solve my issue, uploding 100 times firmware then unplug my GPIO 00 port from my module (ESP201) and I didn’t touch any connection ( CHP_EK to Vcc, GPIO15 to GND and RX Tx Vcc and GND is same), then I can connect, I set the my SSID and password then I can connect to QGC.