Error receive Pixhawk 5x sensor data to ROS2

Before explaining the error, my environment is as follows.

IP address : 172.20.10.7
IP address(int32) : -1407972857
The System : Ubuntu20.04 + ROS2
The flight controller : Pixhawk 5X, firmware PX4 v1.14.0
Use uXRCE-DDS middleware for communication

Receive sensor data through Gazebo was successful, but receive sensor data through Pixhawk 5X failed.

Gazebo sensor data
gazebo sensor
gazebo DDS agent

5X sensor data
gqc agent

In my opinion, it seems like it’s not recognizing the port, so I converted the IP address to int32 and configured it in QGC.

5X is connected to the desktop through the Ethernet port.

Is there any part that I might be overlooking here?
I would really appreciate your reply.

Hi @YEJUN
Did you configured the ethernet on the Pixhawk side?

You can check if it is properly working by checking MAVLink over ethernet

Hi @Benja

Yes, thank you for the response. Currently, I have completed everything except for MAVSDK, following the PX4 Ethernet Setup. However, the client is not connecting. Your guidance on this would be a great help to me.

From your previous post, you are running the agent on port 8888
but here I see the client trying to connect to port 9500

The two must match

I know that the two ports should match, but not work on port 8888.
I changed both ports to 9500 and tried to connect.
However, it still not work, so i shared my situation through a message.
I would appreciate it if you check. Thank you.

Did you check:

  1. That you can ping the Pixhawk?
  2. That MAVLink over Ethernet works?
  1. It is not possible.
  2. Not works MAVLink over Ethernet.

As a beginner in dealing with PX4, I’m not sure which direction to take for resolving issues.