Drone not taking off in Offboard Mode

Hi folks,

I have a X500 V2 frame with Pixhawk 5x, Raspberry Pi 4 and Vicon System setup.

I’m using microRTPS bridge (ROS2-PX4). I checked on RViz and the data from Vicon is being received really good.

My problem is, I can fly stabilized, manual and position really okay, but when I try to fly Offboard Mode, the drone can’t take off. The takeoff is detected. But its like the drone does not have enough throttle to lift off. Is there a parameter where I can change the throttle?

It is suppose to be like this? Do I have to take off using Position or Take Off mode and then switch to Offboard?

Kind regards

1 Like

Hello friend,
– offboard need streaming the position/attitude command through mavros before switch to offboard, did u try in gazebo first ?

Hi Leo, I’ve already managed to do it. My drone is already flying Offboard with Vicon.

The problem was some topics of the PX4 flight stack in ROS 2, I’m using microRTPS bridge for the communication.

Thanks anyway!

Hi @gugafelds

How did you manage to fly the drone in offboard mode using microRTPS?. When I run the default example of PX4 it is not running, do I need to change something?.

Thanks anyway

Hi, @MrPotato

Yes, I have managed that after I followed these steps here at the end: Using Vision or Motion Capture Systems for Position Estimation | PX4 User Guide

I don’t know why it has worked after I did that, but it worked haha

P.S.: My drone has not shown a green light when I engaged Position Mode. I’ve monitored that with RVIz and rqt, if the position estimator was matching the Vicon Data.

1 Like

Can we send a screenshot of your drone state /mavros/state? Especially, what are armed, guided, system status infor?