Debugging Ardupilot on Pixhawk4 with Holybro Pixhawk adapter

We have compiled Ardupilot and we need to make some changes and flash it to our Pixhawk4 controller and debug and verify that it works. We just bought and received the Holybro Pixhawk adapter and I connect it to the Pixhawk and to our JLink. I used the 6 pin connect from the adapter to the FMU debug port on the Pixhawk. I used the j-link 20-pin mini connector between the adapter and the JLink. I launched the JLinkGDBServer and selected the device STM32F765II and tried to connect and it cannot connect. The documentation says that it is a STM32F765 processor, but there are 10 different options for that with two more characters at the end. I tried several of them, all with no success. Does anyone see what I am doing wrong?

Here is the output in JLinkGDBServer:

SEGGER J-Link GDB Server V7.88c GUI Version

JLinkARM.dll V7.88c (DLL compiled May 16 2023 15:43:58)

-----GDB Server start settings-----
GDBInit file: none
GDB Server Listening port: 2331
SWO raw output listening port: 2332
Terminal I/O port: 2333
Accept remote connection: yes
Generate logfile: off
Verify download: off
Init regs on start: off
Silent mode: off
Single run mode: off
Target connection timeout: 5000 ms
------J-Link related settings------
J-Link Host interface: USB
J-Link script: none
J-Link settings file: none
------Target related settings------
Target device: STM32F765II
Target device parameters: none
Target interface: SWD
Target interface speed: 4000kHz
Target endian: little

Connecting to J-Link…
J-Link is connected.
Selected loader ‘Default’ for flash bank no. 0 (‘Program flash’ @ 0x8000000).
Selected loader ‘Default’ for flash bank no. 1 (‘Option bytes’ @ 0x1FFF0000).
Selected loader ‘CLK@PB2_nCS@PB6_D0@PC9_D1@PC10_D2@PE2_D3@PD13’ for flash bank no. 2 (‘External QSPI flash’ @ 0x90000000).
Firmware: J-Link EDU Mini V1 compiled May 16 2023 10:45:21
Hardware: V1.00
S/N: 801035297
Feature(s): FlashBP, GDB
Checking target voltage…
Target voltage: 3.28 V
Listening on TCP/IP port 2331
Connecting to target…
ERROR: Could not connect to target.
Target connection failed. GDBServer will be closed…

Best to ask about ArduPilot over at